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This manual describes the functions and operating procedures of GateDX-P.  To ensure 
correct use, please read this manual thoroughly before beginning operation.  After 
reading the manual, keep it in a convenient location for quick reference in the event a 
question arises.  
Gate-DXP is a software program that acquires data from the DX100P/DX200 and 
transfers it to DAQLOGGER or Remote Monitor.  

Note
•	 The contents of this manual are subject to change without prior notice as a result of 

continuing improvements to the software’s performance and functions.
•	 Every effort has been made in the preparation of this manual to ensure the accuracy 

of its contents.  However, should you have any questions or find any errors, please 
contact your nearest YOKOGAWA representative as listed on the back cover of this 
manual.  

•	 Copying or reproducing all or any part of the contents of this manual without the 
permission of Yokogawa Electric Corporation is strictly prohibited.  

•	 Use of this product (software and this manual) on more than one computer at the 
same time is prohibited. Use by more than one user is also prohibited.

•	 Transfer or lending of this product to any third party is prohibited.
•	 Yokogawa Electric Corporation provides no guarantees other than for physical 

deficiencies found on the original disk or this manual upon opening the product 
package.

•	 License numbers will not be reissued. Please keep the license number in a safe 
place.

Copyrights
•	 Copyrights for the programs included on the CD-ROM are attributable to Yokogawa 

Electric Corporation.  

Trademarks
•	 DAQWORX, DAQLOGGER, and DAQEXPLORER are registered trademarks or 

trademarks of Yokogawa Electric Corporation.
•	 Microsoft, Windows, and Windows Vista are registered trademarks or trademarks of 

Microsoft Corporation in the United States and/or other countries.
•	 Adobe and Acrobat are registered trademarks or trademarks of Adobe Systems 

Incorporated.
•	 Company and product names that appear in this manual are registered trademarks or 

trademarks of their respective holders.
•	 The company and product names used in this manual are not accompanied by the 

registered trademark or trademark symbols (® and ™).

Revisions
•	 1st Edition		 June 2003
•	 2nd Edition		 February 2005
•	 3rd Edition		 June 2007
•	 4th Edition		 January 2009
•	 5th Edition		 January 2011
•	 6th Edition		 October 2011
•	 7th Edition		 June 2014
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Software License Agreement

IMPORTANT - PLEASE READ CAREFULLY BEFORE INSTALLING OR USING:
THANK YOU VERY MUCH FOR SELECTING SOFTWARE OF YOKOGAWA ELECTRIC CORPORATION ("YOKOGAWA"). BY INSTALLING OR OTHERWISE USING THE 
SOFTWARE PRODUCT, YOU AGREE TO BE BOUND BY THE TERMS AND CONDITIONS OF THIS AGREEMENT. IF YOU DO NOT AGREE, DO NOT INSTALL NOR USE 
THE SOFTWARE PRODUCT AND PROMPTLY RETURN IT TO THE PLACE OF PURCHASE FOR A REFUND, IF APPLICABLE. 

Software License Agreement
1. Scope
This Agreement applies to the following software products and associated documentation of Yokogawa (collectively, "Software Product"). Unless otherwise provided by 
Yokogawa, this Agreement applies to the updates and upgrades of the Software Product which may be provided by Yokogawa.
Software Product:  DAQWORX (It is limited to each software that you bought).

2. Grant of License
2.1	Subject to the terms and conditions of this Agreement, Yokogawa hereby grants to you a non-exclusive and non-transferable right to use the Software Product on a 

single or, the following specified number of, computer(s) and solely for your internal operation use, in consideration of full payment by you to Yokogawa of the license fee 
separately agreed upon.

	 Granted number of License:  1 (one)
2.2	Unless otherwise agreed or provided by Yokogawa in writing, the following acts are prohibited:
	 a)	 to reproduce the Software Product, except for one archival copy for backup purpose, which shall be maintained with due care subject to this Agreement;
	 b)	 �to sell, lease, distribute, transfer, pledge, sublicense, make available via the network or otherwise convey the Software Product or the license granted herein to any 

other person or entity;
	 c)	 to use the Software Product on any unauthorized computer via the network;
	 d)	 �to cause, permit or attempt to dump, disassemble, decompile, reverse-engineer, or otherwise translate or reproduce the Software Product into source code or other 

human readable format, or to revise or translate the Software Product into other language and change it to other formats than that in which Yokogawa provided;
	 e)	 to cause, permit or attempt to remove any copy protection used or provided in the Software Product; or
	 f)	 to remove any copyright notice, trademark notice, logo or other proprietary notices or identification shown in the Software Product.
2.3	Any and all technology, algorithms, know-how and process contained in the Software Product are the property or trade secret of Yokogawa or licensors to Yokogawa. 

Ownership of and all the rights in the Software Product shall be retained by Yokogawa or the licensors and none of the rights will be transferred to you hereunder. 
2.4	You agree to maintain the aforementioned property and trade secret of Yokogawa or licensors and key codes in strict confidence, not to disclose it to any party other 

than your employees, officers, directors or similar staff who have a legitimate need to know to use the Software Product and agreed in writing to abide by the obligations 
hereunder.

2.5	Upon expiration or termination of this Agreement, the Software Product and its copies, including extracts, shall be returned to Yokogawa and any copies retained in your 
computer or media shall be deleted irretrievably. If you dispose of media in which the Software Product or its copy is stored, the contents shall be irretrievably deleted.

2.6	The Software Product may contain software which Yokogawa is granted a right to sublicense or distribute by third party suppliers, including affiliates of Yokogawa ("Third 
Party Software"). If suppliers of the Third Party Software ("Supplier") provide special terms and conditions for the Third Party Software which differ from this Agreement, 
the special terms and conditions separately provided by Yokogawa shall prevail over this Agreement. Some software may be licensed to you directly by Supplier. 

2.7	The Software Product may contain open source software ("OSS"), for which the special terms and conditions separately provided by Yokogawa shall take precedence 
over this Agreement.

3. Restrictions on Application
3.1	Unless otherwise agreed in writing between you and Yokogawa, the Software Product is not intended, designed, produced or licensed for use in relation to aircraft 

operation or control, ship navigation or marine equipment control, or ground facility or device for support of the aforesaid operation or control, or for use in relation to rail 
facility, nuclear related facility, radiation-related equipment, or medical equipment or facility, or under any other circumstances which may require high safety standards.

3.2	If the Software Product is used for the abovementioned purposes, neither Yokogawa nor Supplier assumes liability for any claim or damage arising from the said use 
and you shall indemnify and hold Yokogawa, Supplier, their affiliates, subcontractors, officers, directors, employees and agents harmless from any liability or damage 
whatsoever, including any court costs and attorney's fees, arising out of or related to the said use.

4. Limited Warranty
4.1	The Software Product shall be provided to you on an "as is" basis at the time of delivery and except for physical damage to the recording medium containing the Software 

Product, Yokogawa and Supplier shall disclaim all of the warranties whatsoever, express or implied, and all liabilities therefrom.  If any physical defect is found on the 
recording medium not later than twelve (12) months from delivery, Yokogawa shall replace such defective medium free of charge, provided that the defective medium 
shall be returned to the service office designated by Yokogawa at your expense within the said twelve (12) months.  THIS LIMITED WARRANTY PROVIDED IN THIS 
CLAUSE IS IN LIEU OF ALL OTHER WARRANTIES OF ANY KIND WHATSOEVER AND YOKOGAWA HEREBY DISCLAIMS ALL OTHER WARRANTIES RELATING 
TO THE SOFTWARE PRODUCT, WHETHER EXPRESSED OR IMPLIED, INCLUDING WITHOUT LIMITATION, ANY IMPLIED WARRANTIES OF MERCHANTABILITY, 
FITNESS FOR ANY PARTICULAR PURPOSE, NON-INFRINGEMENT, QUALITY, FUNCTIONALITY, APPROPRIATENESS, ACCURACY, RELIABILITY AND RECENCY.  
IN NO EVENT SHALL YOKOGAWA WARRANT THAT THERE IS NO INCONSISTENCY OR INTERFERENCE BETWEEN THE SOFTWARE PRODUCT AND OTHER 
SOFTWARE NOR SHALL BE LIABLE THEREFOR. The warranty provisions of the applicable law are expressly excluded to the extent permitted.

4.2	At the sole discretion of Yokogawa, Yokogawa may upgrade the Software Product to the new version number ("Upgrade") and make it available to you at your expense 
or free of charge as Yokogawa deems fit.  In no event shall Yokogawa be obliged to upgrade the Software Product or make the Upgrade available to you.

4.3	Certain maintenance service may be available for some types of Software Product at Yokogawa's current list price. Scope and terms and conditions of the maintenance 
service shall be subject to those separately provided by Yokogawa. Unless otherwise provided in Yokogawa catalogues or General Specifications, maintenance services 
will be available only for the latest version and the immediately preceding version. In no event will service for the immediately preceding version be available for more than 
5 years after the latest version has been released. In addition, no service will be provided by Yokogawa for the Software Product which has been discontinued for more 
than 5 years. Notwithstanding the foregoing, maintenance service may not be available for non-standard Software Product. Further, in no event shall Yokogawa provide 
any service for the Software Product which has been modified or changed by any person other than Yokogawa.
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5. Infringement
5.1	If you are warned or receive a claim by a third party that the Software Product in its original form infringes any third party's patent (which is issued at the time of delivery 

of the Software Product), trade mark, copyright or other intellectual property rights ("Claim"), you shall promptly notify Yokogawa thereof in writing.
5.2	If the infringement is attributable to Yokogawa, Yokogawa will defend you from the Claim at Yokogawa's expense and indemnify you from the damages finally granted by 

the court or otherwise agreed by Yokogawa out of court. The foregoing obligation and indemnity of Yokogawa shall be subject to that i) you promptly notify Yokogawa of 
the Claim in writing as provided above, ii) you grant to Yokogawa and its designees the full authority to control the defense and settlement of such Claim and iii) you give 
every and all necessary information and assistance to Yokogawa upon Yokogawa's request.

5.3	If Yokogawa believes that a Claim may be made or threatened, Yokogawa may, at its option and its expense, either a) procure for you the right to continue using the 
Software Product, b) replace the Software Product with other software product to prevent infringement, c) modify the Software Product, in whole or in part, so that it 
become non-infringing, or d) if Yokogawa believes that a) through c) are not practicable, terminate this Agreement and refund you the paid-up amount of the book value 
of the Software Product as depreciated.

5.4	Notwithstanding the foregoing, Yokogawa shall have no obligation nor liability for, and you shall defend and indemnify Yokogawa and its suppliers from, the Claim, if the 
infringement is arising from a) modification of the Software Product made by a person other than Yokogawa, b) combination of the Software Product with hardware or 
software not furnished by Yokogawa, c) design or instruction provided by or on behalf of you, d) not complying with Yokogawa's suggestion, or e) any other causes not 
attributable to Yokogawa.

5.5	This section states the entire liability of Yokogawa and its suppliers and the sole remedy of you with respect to any claim of infringement of a third party's intellectual 
property rights. Notwithstanding anything to the contrary stated herein, with respect to the claims arising from or related to the Third Party Software or OSS, the special 
terms and conditions separately provided for such Third Party Software or OSS shall prevail.

6. Limitation of Liability
6.1	EXCEPT TO THE EXTENT THAT LIABILITY MAY NOT LAWFULLY BE EXCLUDED IN CONTRACT, YOKOGAWA AND SUPPLIERS SHALL NOT BE LIABLE TO ANY 

PERSON OR LEGAL ENTITY FOR LOSS OR DAMAGE, WHETHER DIRECT, INDIRECT, SPECIAL, INCIDENTAL, CONSEQUENTIAL OR EXEMPLARY DAMAGES, 
OR OTHER SIMILAR DAMAGES OF ANY KIND, INCLUDING WITHOUT LIMITATION, DAMAGES FOR LOSS OF BUSINESS PROFITS, BUSINESS INTERRUPTION, 
LOSS OR DESTRUCTION OF DATA, LOSS OF AVAILABILITY AND THE LIKE, ARISING OUT OF THE USE OR INABILITY TO USE OF THE SOFTWARE PRODUCT, 
OR ARISING OUT OF ITS GENERATED APPLICATIONS OR DATA, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGES, WHETHER BASED IN 
WARRANTY (EXPRESS OR IMPLIED), CONTRACT, STRICT LIABILITY, TORT (INCLUDING NEGLIGENCE), OR ANY OTHER LEGAL OR EQUITABLE GROUNDS.  
IN NO EVENT YOKOGAWA AND SUPPLIER'S AGGREGATE LIABILITY FOR ANY CAUSE OF ACTION WHATSOEVER (INCLUDING LIABILITY UNDER CLAUSE 
5) SHALL EXCEED THE DEPRECIATED VALUE OF THE LICENSE FEE PAID TO YOKOGAWA FOR THE USE OF THE CONCERNED PART OF THE SOFTWARE 
PRODUCT. If the Software Product delivered by Yokogawa is altered, modified or combined with other software or is otherwise made different from Yokogawa catalogues, 
General Specifications, basic specifications, functional specifications or manuals without Yokogawa's prior written consent, Yokogawa shall be exempted from its 
obligations and liabilities under this Agreement or law.

6.2	Any claim against Yokogawa based on any cause of action under or in relation to this Agreement must be given in writing to Yokogawa within three (3) months after the 
cause of action accrues. 

7. Export Control
 You agree not to export or provide to any other countries, whether directly or indirectly, the Software Product, in whole or in part, without prior written consent of Yokogawa. 
If Yokogawa agrees such exportation or provision, you shall comply with the export control and related laws, regulations and orders of Japan, the United States of America, 
and any other applicable countries and obtain export/import permit and take all necessary procedures under your own responsibility and at your own expense. 

8. Audit; Withholding
8.1	Yokogawa shall have the right to access and audit your facilities and any of your records, including data stored on computers, in relation to the use of the Software Product 

as may be reasonably necessary in Yokogawa's opinion to verify that the requirements of this Agreement are being met.
8.2	Even after license being granted under this Agreement, should there be any change in circumstances or environment of use which was not foreseen at the time of delivery 

and, in Yokogawa's reasonable opinion, is not appropriate for using the Software Product, or if Yokogawa otherwise reasonably believes it is too inappropriate for you to 
continue using the Software Product, Yokogawa may suspend or withhold the license provided hereunder.

9. Assignment
If you transfer or assign the Software Product to a third party, you shall expressly present this Agreement to the assignee to ensure that the assignee comply with this 
Agreement, transfer all copies and whole part of the Software Product to the assignee and shall delete any and all copy of the Software Product in your possession 
irretrievably. This Agreement shall inure to the benefit of and shall be binding on the assignees and successors of the parties.

10. Termination
Yokogawa shall have the right to terminate this Agreement with immediate effect upon notice to you, if you breach any of the terms and conditions hereof. Upon termination of 
this Agreement, you shall promptly cease using the Software Product and, in accordance with sub-clause 2.5, return or irretrievably delete all copies of the Software Product, 
certifying the same in writing. In this case the license fee paid by you for the Software Product shall not be refunded. Clauses 2.4 and 2.5, 3, 5, 6 and 11 shall survive any 
termination of this Agreement.

11. Governing Law; Disputes
This Agreement shall be governed by and construed in accordance with the laws of Japan. 
 Any dispute, controversies, or differences which may arise between the parties hereto, out of, in relation to or in connection with this Agreement ("Dispute") shall be resolved 
amicably through negotiation between the parties based on mutual trust. Should the parties fail to settle the Dispute within ninety (90) days after the notice is given from either 
party to the other, the Dispute shall be addressed in the following manner:
	 (i)	 If you are a Japanese individual or entity, the Dispute shall be brought exclusively in the Tokyo District Court (The Main Court) in Japan.
	 (ii)	 �If you are not a Japanese individual or entity, the Dispute shall be finally settled by arbitration in Tokyo, Japan in accordance with the Commercial Arbitration Rules 

of the Japan Commercial Arbitration Association. All proceedings in arbitration shall be conducted in the English language, unless otherwise agreed. The award of 
arbitration shall be final and binding upon both parties, however, each party may make an application to any court having jurisdiction for judgment to be entered on 
the award and/or for enforcement of the award.

12. Miscellaneous
12.1	 This Agreement supersedes all prior oral and written understandings, representations and discussions between the parties concerning the subject matter hereof to 

the extent such understandings, representations and discussions should be discrepant or inconsistent with this Agreement.
12.2	 If any part of this Agreement is found void or unenforceable, it shall not affect the validity of the balance of the Agreement, which shall remain valid and enforceable 

according to its terms and conditions. The parties hereby agree to attempt to substitute for such invalid or unenforceable provision a valid or enforceable provision that 
achieves to the greatest extent possible the economic, legal and commercial objectives of the invalid or unenforceable provision.

12.3	 Failure by either party to insist on performance of this Agreement or to exercise a right when entitled does not prevent such party from doing so at a later time, either 
in relation to that default or any subsequent one.

End of document

Software License Agreement
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Overview of This Manual

Structure of This Manual
This user’s manual consists of the following chapters.  

Chapter Title Description
1 Overview Gives an overview of the GateDX-P software.  

Lists the PC requirements for running Gate-DXP and 
gives information about system configuration.  

2 Operating Procedure Gives procedures for entering environment and data 
logging interval settings, and how to monitor the 
operational status of the software.  

3 Detailed Description of 
Functions

Provides a detailed description of the functions of 
GateDX-P.  Lists error messages, their causes, and their 
corrective actions.  

Index An alphabetical index of the manual's contents.

Scope of This Manual
This manual does not explain the basic operations of your PC's operating system (OS).
For information regarding the basic operations of Windows, see the Windows user’s 
manual.

Conventions Used in This Manual
•	 Units
	 K	 Denotes 1024.	 Example: 10 KB
	 M	Denotes 1024K.	 Example: 10 MB
	 G	 Denotes 1024M.	 Example: 2 GB

•	 Boldface Type
	 Hardware and software controls that the user manipulates such as dialog boxes, 

buttons, and menu commands are often set in boldface type.

•	 Subheadings
	 On pages in chapters 1 through 3 that describe operating procedures, the following 

subheadings are used to distinguish the procedure from their explanations.

			 

Procedure This subsection contains the operating procedure used to carry out
the function described in the current section. All procedures are
written with inexperienced users in mind; experienced users may
not need to carry out all the steps.

			   Note Calls attention to information that is important for proper operation 
of the instrument.
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Chapter 1	 Overview

1.1 Overview of GateDX-P Functions

Gate-DXP is a software program that acquires data from the DX100P/DX200 and 
transfers it to DAQLOGGER or Remote Monitor.  Using GateDX-P allows you to monitor 
data on DAQLOGGER or Remote Monitor that is measured on the DX100P or DX200P.  
Yokogawa’s DAQLOGGER is a software program that allows users to open a connection 
from their PC to various kinds of Yokogawa recorders (the mR, VR, DARWIN, DX, MV, 
and CX) and perform data logging and monitoring.  
Yokogawa’s Remote Monitor is application software that enables monitoring of data 
logged by recorders or data logging software.  

Features
•	 Runs as a Windows application.  
•	 Up to 16 DX100P/DX200Ps can be linked.  
•	 Measurement can be performed at intervals of up to 0.5 seconds*.  

*	 However, DAQLOGGER’s shortest interval is 1 second.  Also, the maximum speed of 0.5 
seconds may not be attainable depending on the amount of data being read, the response 
time of the device, and the communication speed.  
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1.2 System Overview

System
This software can connect with and download data from DX100P/DX200Ps having the 
following characteristics. 
•	 DX100P:	 Style 4 or later.  The /C2 option is required for RS-232 communications.  	

	 	 	 	 The /C3 option is required for RS-422-A/485 communications.  
•	 DX200P:	 Style 4 or later.  The /C2 option is required for RS-232 communications.  	

				    The /C3 option is required for RS-422-A/485 communications.  

Required Operating Systems
Run DAQWORX under any of the following operating systems. 
•	 Windows Vista Home Premium SP2 (excluding the 64-bit editions)
•	 Windows Vista Business SP2 (excluding the 64-bit editions)
•	 Windows 7 Home Premium, SP1 (32-bit and 64-bit editions)
•	 Windows 7 Professional, SP1 (32-bit and 64-bit editions)
•	 Windows 8 (32-bit and 64-bit) (Supports the desktop mode)
•	 Windows 8 Pro (32-bit and 64-bit) (Supports the desktop mode)
The language displayed by the software under different language versions of the OS are 
as follows. 
OS Language Software Language
Japanese Japanese
Other English

Hardware Requirements
The following hardware is required to use GateDX-P.  
•	 PC:	 	 	 	 	 	 �A PC that runs one of the OS above, and that meets the 

following CPU and memory requirements. 
								        When Using Windows Vista
	 	 	 	 	 	 	 	 Pentium 4, 3 GHz or faster Intel x64 or x86 processor; 2 GB or 	

							       more of memory
								        When Using Windows 7 or Windows 8
	 	 	 	 	 	 	 	 32-bit edition: Intel Pentium 4, 3 GHz or faster x64 or x86 	

	 	 	 	 	 	 	 processor; 2 GB or more of memory 
	 	 	 	 	 	 	 	 64-bit edition: Intel x64 processor that is equivalent to Intel 	

	 	 	 	 	 	 	 Pentium 4, 3 GHz or faster; 2 GB or more of memory
•	 Free disk space: 	 200 MB or more 
•	 Communication device:	 An Ethernet (when connecting to DAQLOGGER or Remote 

Monitor), RS-232, or GPIB port that is recognized by the 
operating system.  

•	 CD-ROM drive:	 	 Used to install the software
•	 Peripheral devices:	 A mouse supported by the operating system
•	 GP-IB port:		 	 	 �Required for GPIB communications between the software and 

a WT series instrument
•	 Monitor:		 	 	 	 A video card that is recommended for the OS and a display 	

	 	 	 	 	 	 	 that is supported by the OS, has a resolution of 1024×768 or 	
	 	 	 	 	 	 	 higher, and that can show 65,536 colors (16-bit, high color) or 	
							       more.
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1.2  System Overview

Note
An RS-232 to RS-422-A/485 converter is required to perform communications between the 
software and another DX100P/DX200P via RS-422-A/485 (Yokogawa ML2 RS232C/RS485 
recommended).
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System Configuration

		

GateDX-P

Up to 16 DX100P/DX200Ps

TCP/IP connection
Monitor server protocol
Data transfer Remote Monitor

Converter

It is recommended that you run GateDX-P and DAQLOGGER on separate PCs.  

Software Configuration

	

DX100P/DX200P

DAQLOGGER

Ethernet

Ethernet

GateDX-P

Environment setting 
functions

Displays execution 
status

Writes to file

Environment 
settings file

File read out

Status information

Executable 
function

Remote MonitorSerial 
 communications

GateDX-P Configurator consists of two separate software functions.  The role of each 
function within the configurator is as follows:
•	 Environment Setting Functions
	 Acts as the user interface for GateDX-P.  
	 These functions allow the user to enter various settings required by the executable 

function for communications with the DX100P/DX200P, as well as those required for 
data transfers to and from DAQLOGGER and Remote Monitor.  The user can also 
use the environment setting functions to start/stop the executable function, or view the 
execution status.  

•	 Executable Function
	 The software reads data from the DX100P/DX200P at fixed intervals.  It also acts as a 

monitor server, transferring data to DAQLOGGER and Remote Monitor.

1.2  System Overview



2-1IM WX1-02E

1

2

3

Index

O
peration Procedure

Chapter 2	 Operation Procedure

2.1 Running and Exiting GateDX-P

Running the Software
Procedure

1.	 From the Windows Start menu, choose Programs > YOKOGAWA DAQWORX > 
GateDXP > GateDX-P.  

	 The Gate-DX-P Configurator opens, displaying the user interface.

					      

Note
•	 When you start GateDX-P it is restored to the same status that was active during the 

previous session.
•	 If the program is closed while a process or service is running, the license will be considered 

to be “in use.” If the message, “Invalid license number. Please reinstall.” appears when 
restarting the program, it may indicate that the user is attempting to run a Gate program in 
excess of the number of available licenses. 

Starting GateDX-P in Acquisition Start Mode
1.	 From the Windows Start menu, choose Programs > YOKOGAWA DAQWORX > 

GateDXP > GateDX-P, then right-click GateDX-P and select Create Shortcut.  

2.	 Right-click the shortcut icon and select Properties.  
3.	 Choose the Shortcut tab, then add /START to the right of the path in the Target 

box and click OK.  

					   

4.	 Choose the shortcut from the Windows Start menu.  The connection status of the 
previous session is restored, and acquisition begins. 

Exiting the Software
Procedure

1.	 Choose File > Exit from the menu bar, or click the X button at the right end of the 
title bar.  

	 GateDX-P closes.  
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2.2 Entering Environment Settings

The following settings can be entered using the configurator.  
•	 DX100P/DX200P assignments, communications settings, and login settings
•	 Acquisition interval settings for each DX100P/DX200P
•	 Port number settings (for the monitor server) as needed
•	 The settings can be saved 

Serial Port Settings
Procedure

1.	 Click the Serial Setting tab or choose View > Serial Setting from the menu bar.  
The Serial Setting tab is displayed.

Drag to select the 
desired items

Turns the selected items ON and OFF

Click to display a list

Copies the setting in the 
first item of the selection 
to all of the items in the 
selectio

2.	 Enter settings for each item.
	 Port number:	 ON (blue)/OFF (gray)
	 Type:	 	 RS-232-C, RS-422-A/485
	 Baud rate:	 9600,19200,38400
	 Parity:	 	 NONE, ODD, EVEN

Recorder Settings
Procedure

1.	 Click the Recorder Setting tab or choose View > Recorder Setting from the 
menu bar.  

	 The Recorder Setting tab is displayed.

Drag to select the items 
for automatic model 
determination

Click to display a list

Only the active COM ports 
(specified in serial port 
settings) are displayed
Click to display the Input 
Address dialog box



2-3IM WX1-02E

1

2

3

Index

O
peration Procedure

2.2  Entering Environment Settings

Port Settings
2.	 Enter the port and address.  
	 Port:	 �Select the port to be used for the connection.  Only the numbered COM 

ports turned ON in the license setting tab are displayed.  
	 For Ports Set to Ethernet

	 	 Click a cell in the address column to open the dialog box in the figure below.

						    

		  Enter the following settings.  
		  IP address or host name: 	enter the IP address or host name of the DX100P/

DX200P to which you wish to connect.  
	 	 User name: 	 enter the user name specified on the DX100P/DX200P to which 

you wish to connect.  
	 	 User ID: 	 enter the user ID specified on the DX100P/DX200P to which 

you wish to connect.  
	 	 Password: 	 enter the password specified on the DX100P/DX200P to which 

you wish to connect. 
 

Note
	 When logging on to the DX100P/DX200P from GateDX-P, the default password for the 

DX100P/DX200P cannot be used.  If it is used, login will fail.
 

	 For Ports Set to COM
	 Click a cell in the address column to open the dialog box in the figure below.

				  

	 Select an RS-422-A address.  

	 Address: only valid for COM ports using Ethernet or RS-422-A/485.  
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2.2  Entering Environment Settings

Automatic Model Determination
3.	 You can drag to select the items for automatic model determination.  

4.	 Click Auto determination on the toolbar or choose Communication > Recorder 
Model Determination from the menu bar.

					   
Auto determination button

	

	 The following items are displayed.  
	 Model:			�   The specific DX100P/DX200P models to be 

connected.  
	 Measurement channels:	� The number of measurement channels on the 

connected DX100P/DX200P.  
	 Math channels:		�  The number of math channels on the connected 

DX100P/DX200P.

				  

Scan Interval and Retry Settings
Procedure

1.	 Click the Scan Interval Setting tab or choose View > Scan Interval Setting from 
the menu bar.  

	 The Scan Interval Setting tab is displayed.
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Setting the Scan Interval
2.	 Specify a scan interval from 0.5 to 3600 seconds.  

Setting the Number of Retries
3.	 Turn the communication retry setting ON or OFF.  

4.	 Enter the time interval between retries.
	 Setting range: 30–3600 seconds

Port Settings
Procedure

1.	 Click the Port Setting tab or choose View > Port setting from the menu bar.  
	 The Port Setting tab is displayed.

					   

2.	 You can change the port number used by the monitor server.  

Saving Environment Settings 
Procedure

1	 Click the Save button on the tool bar or choose File > Save from the menu bar.

					   
Save button

2.2  Entering Environment Settings
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2.3	 Connecting from DAQLOGGER or Remote 
Monitor

While the executable function is running, DAQLOGGER or Remote Monitor works via 
Ethernet to log and monitor the data that the DX100P/DX200P is acquiring.  Gate-DXP’
s executable function acts as the client of a DAQLOGGER or Remote Monitor that is 
running as the monitor server.  

In this case, system numbers are assigned as follows:
	 DX100P/DX200P assigned to Recorder1: 0
	 DX100P/DX200P assigned to Recorder2: 1

Connecting from DAQLOGGER
Procedure

See section 2.6 of the WX101 DAQLOGGER WX81 DAQLOGGER Client Package User’
s Manual (IM WX101-01E).  

Connecting from Remote Monitor
Procedure

See section 8.1 of the WX101 DAQLOGGER WX81 DAQLOGGER Client Package User’
s Manual (IM WX101-01E), or section 9.2 of the WX102 DAQ32Plus WX82 DAQ32Plus 
Client Package User’s Manual (IM WX102-01E).  
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2.4 Process Run/Stop and Service Run/Stop

Running/Stopping from the Menu Bar
Procedure

Running as a Process or Service
1.	 Click the Service execution or Process execution button on the tool bar.  Or, 

choose Execute > Service or Execute > Process from the menu bar.  
	 The executable function starts as a process or service.  “Service” or “Process” is 

displayed under Practice Status on the Practice Status tab.

					     Stop button
Process execution button

Service execution button

Note
•	 Service execution can only be specified by users with Administrator privileges.  
•	 Services cannot be executed when using Windows Vista. 

Stopping the Process or Service
1.	 Click the Stop button on the tool bar or choose Execute > Stop from the menu bar.  
	 The Practice Status item shown on the Practice/Status tab displays “Stop.”  

Running/Stopping the Executable Function from the Execution/Status Tab 
Procedure

1.	 Click the Execution/Status tab or choose View > Execution/Status from the menu bar.  
	 The Execution/Status tab is displayed.

	

Select the practice type

Running as a Process or Service
2.	 Select to execute the function as a process or service.  
3.	 Click Practice.
	 The executable function starts, and “Service” or “Process” is displayed under 

Practice Status.  

Stopping the Process or Service
2.	 Click the Stop button.  
	 “Stop” is displayed for the practice status.  
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2.5 Viewing the Status of the Executable Function

Procedure
Displaying the Connection Status

1.	 Click the Execution/Status tab, or choose View > Execution/Status from the 
menu bar.  

	 The Execution/Status tab is displayed, allowing you to see the method under 
which the executable function may be running (as a process or as a service), 
whether or not it is running, and with which PCs communications are open.

					   

Displays the names 
of connected clients

Double-click to 
display the Error 
Indicator dialog box

Select the 
practice type

Displays the communications status with the client
  Gray: Stopped
  Red: Error
  Green: Normal

Viewing Error Detail 
2.	 Double-click the box displaying the client communication status on the Execution/

Status tab (shown above).  
	 The Error Indicator dialog box opens.

					   

	 See section 3.3 for error messages. 

Note
•	 If a warning message is displayed (code Wxxxx), the lamp that displays the connection 

status by color does not blink red.  
•	 When an error occurs and the lamp blinks red, the Error Indicator dialog box appears.  If you 

close the dialog box, the lamp turns green.
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2.6 Viewing Version Information

Procedure
1.	 Click the About button on the tool bar or choose Help > About from the menu bar.

					   
About button

	 The Version dialog box opens.

					   

License number

Version

Company name
User name
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Chapter 3	 Detailed Description of Functions

3.1 Overview

Gate-DXP performs Ethernet communications with the DX100P/DX200P and acquires 
data at regular intervals. Through the monitor server function, the acquired data is 
transferred to DAQLOGGER or Remote Monitor via Ethernet.  
The following is a list of the features of each software function. 

Environment Setting Functions
Environment setting functions are used to enter all environment settings required to run 
the executable function.  
•	 Serial Port Settings (as Needed)
	 Port
	 Type (RS-422A/485 or RS-232-C)
	 Baud rate
	 Parity
•	 Recorder Settings
	 Port
	 Address
	 User name
	 User ID
	 Password
	 Automatic model determination
•	 Scan Interval Settings
	 Scan interval setting for each recorder (0.5 to 3600 sec.)
	 Communication retry ON and OFF
	 Retry interval
•	 Port Settings
	 Port number for monitor server
	 Port number for getting status
•	 Executable Function Start/Stop
	 Runs as a service
	 Runs as a process
•	 Executable Function Status Display
	 Practice status display (stopped, running as a service, running as a process)
	 Display of the connection status from the client

Executable Function
Features of the executable function are as follows:
•	 Running as a process and as a service is possible. 
•	 Instantaneous data values are acquired from up to 16 DX100p/DX200Ps at regular 

intervals.  
•	 Runs as a monitor server via Ethernet if DAQLOGGER or Remote Monitor is the 

client.  
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3.2 Detailed Description of Functions

Serial Port Settings
GateDX-P can use the COM1–COM9 serial ports.  
The user must enter the following port settings. 
•	 Use/Do not use (ON/OFF)
•	 Type (RS-422-A/485 or RS-232-C)
•	 Baud rate: 4800, 9600, 19200, 38400 bps
•	 Parity bit: NONE, ODD, EVEN

Recorder Settings
GateDX-P allows simultaneous connection with any combination of 16 DX100p/
DX200Ps.  
The user must enter the following recorder settings. 
•	 Port (COMx or Ethernet)
•	 Address number (if a COM port using RS-422-A/485 is selected)
•	 IP address or host name (if Ethernet is selected for the port)
•	 User name (if Ethernet is selected for the port)
•	 User ID (if Ethernet is selected for the port)
•	 Password (if Ethernet is selected for the port)
•	 Automatic Model Determination
If communication settings are entered correctly, the models, number of measurement 
channels, and number of computation channels are identified by the software.  

Scan Interval
A scan interval from 0.5 to 3600 seconds is selected for each of the 16 DX100P/
DX200Ps.  

Note
When connecting to DAQLOGGER and acquiring data from the DX100P/DX200P, if GateDX-P’
s scan interval is longer than that of DAQLOGGER, DAQLOGGER logs the same data 
repeatedly until the next Gate-DXP scan interval.  Therefore, it is recommended that GateDX-P’
s scan interval be set to a value smaller than DAQLOGGER’s scan interval. 

 

Communication Retry
Using the Configurator, you can turn communication retry ON and OFF, and set the retry 
interval.  
•	 When Communication Retry Is OFF
	 After detecting that communications were cut, no attempts are made to reconnect.  
•	 When Communication Retry Is ON
	 After detecting that communications were cut, the software attempts to reconnect 

after the retry interval has elapsed.  Even if the reconnection resulted in an error, 
the software waits again for the retry interval to elapse, then attempts another 
reconnection.  This process repeats until a valid connection is opened.  

	 A communication retry interval of 30 to 3600 seconds can be entered.  

Note
GateDX-P considers communications to have been cut in the following circumstances.  
•	 If the executable function requests data from a DX100P/DX200P but no response is 

received within 10 seconds.  
•	 f the software detects that the TCP/IP connection was dropped when the executable 

function is connected to the DX100P/DX200P via Ethernet.
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Port Settings
GateDX-P uses the following ports.  
•	 Monitor Server Port
	 The TCP/IP port number used for communication with DAQLOGGER or Remote 

Monitor.  

Running/Stopping the Executable Function
The user interface allows you to start and stop the executable function.  
The executable function runs under one of the following two methods or “types.”  
•	 Process Run/Stop
	 The executable function is run/stopped as a process.  
•	 Service Run/Stop
	 The executable function is registered as an automatically executing service, then 

run.  After an executable function running as a service is stopped, its registration as 
a service is deleted.  As indicated by the service execution status, the executable 
function continues processing even when the user has logged off of Windows.  
Also, the software is automatically run as a service when the computer is turned 
ON.  Service execution can only be specified by users with Administrator privileges. 
Services cannot be executed when using Windows Vista.

Monitor Server Function of the Executable Function
When the executable function is running, you can connect from DAQLOGGER or 
Remote Monitor via Ethernet using the remote monitor protocol, and acquire data.  In this 
case, system numbers are assigned as follows:
	 DX100P/DX200P assigned to Recorder1: system number 0
	 DX100P/DX200P assigned to Recorder2: system number 1

Executable Function Status Display
The user interface allows you to display status items for the executable function.  
The information that can be displayed is as follows:
•	 Practice status (stopped, running as a service, running as a process)
•	 Connection status from the client
	 Displays a list of PCs running DAQLOGGERS and Remote Monitors with which the 

executable software has opened a connection.  

Group and Channel Assignments
When connected to GateDX-P using Remote Monitor, the initial status of group and 
channel assignments are as follows:  

			   Group Name	 Waveform Number	 Channel Assignment
Group 1	 Measure Ch	 W01	 CH01
	 	 	 	 •••	 •••
				    W30	 CH30
Group 2	 Math Ch	 W01	 CH31
	 	 	 	 •••	 •••
	 	 	 	 W30	 CH60

Note
When connecting DAQLOGGER to Gate-DXP, group and waveform assignments are ignored.

3.2  Detailed Description of Functions
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3.2  Detailed Description of Functions
 

Channel Names, Tag IDs, and Tag Names
When connected to GateDX-P using Remote Monitor, the channel names, tag IDs, and 
tag name assignments are as follows:  
DX100P/DX200P Channel	 Channel Name	 Tag ID	 Tag Name
CH01		 CH01	 CH01	 DX100P/DX200P tagname
•••		 	 •••	 •••	 •••
CH60		 CH60	 CH60	 DX100P/DX200P tag name

Note
When connecting DAQLOGGER to Gate-DXP, channel names and tag IDs are ignored.  You 
can download tag names using tag setting software.

Channel Colors
The default channel colors on GateDX-P are those specified on the connected DX100P/
DX200P.
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3.3 Error Messages and Corrective Actions

Error
No. Message Corrective Actions
E211 Cannot write to file. Check if the disk capacity is sufficient or if the file systems is 

normal.
E212 Cannot read file. Check if the file exists and is supported by the software or if the 

file system is normal.
E213 Cannot open file. Check if the file exists and is supported by the software or if the 

file system is normal
E401 Communication error. Check if the recorder connected for communication is powered on 

and if the cable is properly connected.  Also check the following 
items according the the communication type.
• For Ethernet
  �Check if address settings are correct; the TCP/IP protocol is 
installed in Windows; the Ethernet card is properly installed.
• For RS-232 and RS-422-A
  �Check if the baud rate settings match; the port (COM1 to COM9) 
settings match, the address settings are correct (RS-422-A); the 
serial port of the PC is active and the appropriate cable is being 
used.

E402 Communication timeout. -
E403 Cannot open a communication port. Same as E401.
E501 Invalid license number.

Please reinstall the software.
E1001 Login error. Check the user name, user ID, and password on the DX-P.
E1002 Invalid password. -
E1003 Password is not valid. -
E1004 Password expired. -

Please set up a password again on the DX-P.
E1010 Execution of aprocess failed. Check whether an executable function exists, or whether its 

files are damaged.  If this error appears frequently, reinstall the 
software.

E1011 Execuition of a service failed. Check whether an executable function exists, or whether its 
files are damaged.  If this error appears frequently, reinstall the 
software.

E1012 Login prohibited because another user is 
logged in.

-

Message
No. Message
M1201 Model determination was successful.
M1210 Setting changes saved before execution.

Executable Function Messages
No. Message Corrective Actions
W[631] Data Lack Reduce the number of acquired data points or connected 

instruments, or lengthen the scan interval.
E[673] Cannot open communication Same as E401.
E[674] Communication error Same as E401.
E[675] Communication time out Same as E401.
E[700] Cannot login Same as E1013.
E[701] Cannot Get DXP inoformation Check whether the communication status and connected 

instruments matches those specified in the software.  If they do 
not, perform model determination again.

I[606] Recovery Communication Connection recovered. 
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